[Supervisor-users] Setting up for local development

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Supervisor-users] Setting up for local development

Connor Lanigan
Hi Arthur,
while I unfortunately can't help you, I can confirm that exactly the
same problem happens on my machine as well (even on the 3.3-branch).

I also tried the master branch, but on the master branch I already got a
(different) error during "python supervisor/supervisord.py -c
supervisor.conf".

Have you found any way to make the local development environment work in
the meantime?

Best regards,
Connor


> If this user list is not the best way to ask questions, should I open an
> issue on the repo?
>
> Cheers
>
> On Sat, Mar 4, 2017 at 8:55 PM, Arthur Burkart <artburkart at gmail.com> wrote:
>
>> Hi,
>>
>> How does one set up supervisor for local development? I ran
>>
>> cd supervisor
>> git checkout 3.1-branch
>> virtualenv env
>> . env/bin/activate
>> python setup.py develop
>> cp supervisor/skel/sample.conf supervisor.conf
>> python supervisor/supervisord.py -c supervisor.conf
>> sudo python supervisor/supervisorctl.py update
>>
>> But I get this error:
>>
>> Traceback (most recent call last):
>>   File "supervisor/supervisorctl.py", line 34, in <module>
>>     from supervisor.medusa import asyncore_25 as asyncore
>> ImportError: No module named supervisor.medusa
>>
>> It's not exactly clear to me what I'm doing wrong. Any assistance would be
>> much appreciated :)


_______________________________________________
Supervisor-users mailing list
[hidden email]
https://lists.supervisord.org/mailman/listinfo/supervisor-users