[Supervisor-users] Amazon Linux Package

classic Classic list List threaded Threaded
3 messages Options
rod
Reply | Threaded
Open this post in threaded view
|

[Supervisor-users] Amazon Linux Package

rod
Hi,

Does anyone have information about if there are any supervisor 3.0 packages available for Amazon Linux or CentOS?

Thanks.

_______________________________________________
Supervisor-users mailing list
[hidden email]
https://lists.supervisord.org/mailman/listinfo/supervisor-users
Reply | Threaded
Open this post in threaded view
|

Re: [Supervisor-users] Amazon Linux Package

Jens Rantil
Forwarding Rod's reply mailing list...

/J

On 22 jan 2014, at 09:50, rod <[hidden email]> wrote:

> Hi Jens,
>
> Thanks for the answer.  I saw the Pip method of installing, but was just hoping for a packaged version somewhere as it would play more nicely with the rest of my deployment.
>
> The problem I'm having stemmed from trying to use the 'directory' and 'environment' configuration options in my program section, then realising that they were only available in version 3.0 and my versions seems to be 2.1.  I can't find any documentation on the website for version 2, so started googling and found this...
>
> https://github.com/SMFOSS/supervisor2
>
> But that seems to contain the same documentation as the website - so now I'm a bit confused about which version I actually have, and where to find the correct docs.  Can you help?
>
> Cheers.
>
>
> On 22 January 2014 07:36, Jens Rantil <[hidden email]> wrote:
> Hi Rod,
>
> I can't answer for for Amazon Linuxor CentOS specifically, but you could always use the Python installer `pip` to installer if those dists don't have supervisor.
>
> Cheers,
> Jens
>
> On 22 jan 2014, at 00:22, rod <[hidden email]> wrote:
>
> > Hi,
> >
> > Does anyone have information about if there are any supervisor 3.0 packages available for Amazon Linux or CentOS?
> >
> > Thanks.
> > _______________________________________________
> > Supervisor-users mailing list
> > [hidden email]
> > https://lists.supervisord.org/mailman/listinfo/supervisor-users
>
>

_______________________________________________
Supervisor-users mailing list
[hidden email]
https://lists.supervisord.org/mailman/listinfo/supervisor-users

signature.asc (990 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Supervisor-users] Amazon Linux Package

Jens Rantil
In reply to this post by rod
Hi again Rod,

The official code base for supervisor is here: https://github.com/Supervisor/supervisor I'm not really sure what the previous link you posted held. Could be an old fork.

Anyhow, I dug through the code:

$ git log "-S'environment'"
...
commit b01dea01a30561ac45b0a918681d744a78b79906
Author: Chris McDonough <[hidden email]>
Date:   Fri Aug 4 02:52:23 2006 +0000

      - New "environment" config file option allows you to add environment
        variable values to supervisord environment from config file.

The following git tags contains that commit:
$ git tag -l --contains b01dea01a30561ac45b0a918681d744a78b79906
3.0
3.0a1
3.0a10
3.0a11
3.0a12
3.0a3
3.0a4
3.0a5
3.0a6
3.0a7
3.0a8
3.0a9
3.0b1
3.0b2

The following git tags does _not_ contain that commit:
2.0b1
2.1b1
2.2b1

Just like you say, it seems tricky to get hold of old documentation. readthedocs usually serve old versions but in supervisor's case it only seems to serve the "latest" version[1].

[1] http://supervisor.readthedocs.org/en/latest/

What does `supervisord --version` (or similar, I don't have supervisor on this computer) give you?

Hope this helps - cheers,
Jens

On 22 jan 2014, at 09:50, rod <[hidden email]> wrote:

> Hi Jens,
>
> Thanks for the answer.  I saw the Pip method of installing, but was just hoping for a packaged version somewhere as it would play more nicely with the rest of my deployment.
>
> The problem I'm having stemmed from trying to use the 'directory' and 'environment' configuration options in my program section, then realising that they were only available in version 3.0 and my versions seems to be 2.1.  I can't find any documentation on the website for version 2, so started googling and found this...
>
> https://github.com/SMFOSS/supervisor2
>
> But that seems to contain the same documentation as the website - so now I'm a bit confused about which version I actually have, and where to find the correct docs.  Can you help?
>
> Cheers.
>
>
> On 22 January 2014 07:36, Jens Rantil <[hidden email]> wrote:
> Hi Rod,
>
> I can't answer for for Amazon Linuxor CentOS specifically, but you could always use the Python installer `pip` to installer if those dists don't have supervisor.
>
> Cheers,
> Jens
>
> On 22 jan 2014, at 00:22, rod <[hidden email]> wrote:
>
> > Hi,
> >
> > Does anyone have information about if there are any supervisor 3.0 packages available for Amazon Linux or CentOS?
> >
> > Thanks.
> > _______________________________________________
> > Supervisor-users mailing list
> > [hidden email]
> > https://lists.supervisord.org/mailman/listinfo/supervisor-users
>
>

_______________________________________________
Supervisor-users mailing list
[hidden email]
https://lists.supervisord.org/mailman/listinfo/supervisor-users

signature.asc (990 bytes) Download Attachment